AnsweredAssumed Answered

Lookup lookup of nintex not filtering using nintex's calculated value

Question asked by rkapiljith on Dec 5, 2015
Latest reply on Apr 12, 2016 by skratsch

i have a nintex form in 2013.

I have a calculated value which pulls information from a list field of type lookup.

Formuale:

lookup("MyList","AccountName",CurrentUser,"SupplierName")

Here the "SupplierName" is a field of type lookup field in SharePoint. I am able to retrieve the value and see its output. But it is pulling the value in the format as : {ITEM ID};#{ITEMVALUE}

Example screen output for the calculated value:

1;#Supplier1

I tried to use the substring function and get the required "SupplierName" as Supplier1 with out the <Item ID> and supporting character sepearation.

But when i use this calculated value on a list lookup to filter, it is not filtering the values.

Can anybody suggest what could be the reason for it?

 

I tried to hardcode the value for the filter in the list lookup as "1:#Supplier" and there the values are getting populated as expected.

 

What could be the reason here for not filter using another control?

 

 

Any help is appreciable.

Outcomes