AnsweredAssumed Answered

Workflow question - date/time not transmitting correctly

Question asked by bccasteel on Nov 13, 2015
Latest reply on Nov 13, 2015 by bccasteel

Hey all,

 

I'm fairly (very) new with Nintex workflows, and I've run across a problem which has me very stumped.

 

I have created a workflow, with the help of a guide, that takes the contents of a repeating section and creates items in a new (child) list that contain the values of the fields in the repeating section. Included in this data is a start date/time and end date/time. The name of the items in the child list contain the start date/time from the originating fields within the repeating section. For example, if the item is based off of a repeating section with a start date/time of November 12, 2015 at 10:00 AM, a portion of the child item's name would be "November 12 2015 10:00 AM". Both lists, source and child, reside on the same site.

 

Now, the problem is this. The items' names indicate that the date and time are being read properly, while the actual values of the fields are 5 hours before the actual dates and times indicated in the parent list item's repeating section. So, if the time in the repeating section is set to 9:00 AM, the time in the child list will be 4:00 AM. I have no idea how to fix this.

Presentation1.jpg

 

A 'quick and dirty' solution would be adding a 'time' and 'time zone' drop-down to the repeating section, and that's my fallback solution still. However, the requirement is to have a calendar built off of the child list and having the times be dropdowns would prevent this.

 

Thanks for any advice on this.

Outcomes