AnsweredAssumed Answered

  Start a task process not delivering email to ‘Assigned to’ user

Question asked by swethasan on Sep 20, 2015
Latest reply on Feb 24, 2016 by swethasan

I have been working on a workflow solution for staff onboard application. The solution had sequential as well as parallel processing blocks for task approvals for which I have been using both

  • Assign a task and
  • Start a task process

All was well and the task assignment notifications were sent as expected to the approver/SharePoint group of approvers (in the case of start a task process) with Lazy Approval enabled. They could reply email with their outcome for the task post which the process flow continues as assigned.

Each of the task assignment task form was edited and customized for ease of approvers, with rules to show ONLY the sections of the form they need to see and not the hundreds of other fields. So far so good eh! 

But then, the past week, task assignment notifications in the parallel processing blocks were not delivered to the approvers.(Cyborg approvers is a custom SharePoint group that is selected conditionally should the user requested access for the same). Nothing got changed in the workflow. Everything was just as it was both in the ‘Start a task process’ and the custom ‘Task form’. But, upon selecting the system

  • User would get notified about submission
  • Sequential task assignments would work as expected sending assignment notifications with hyperlink to URL of item and lazy approval enabled
  • Task process would start
  • Email will NOT be sent to the approver (Swetha Sankaran in the image below)
  • Task will be assigned to them(Not Started in the image below) and everything else would flow as designed

I have been trying to get to the bottom of the issue and understand what was happening. Needless to say the only bottom regarding the issue I found was this.

Google/Bing or Nintex Connect didn’t have much to offer in terms of cause/fix of this issue. At this point, I was not even sure if this ‘WAS’ a real issue.

One thing that did help and set me on the right track was this article on stackexchange: specifically the mention of HTML element in the message  body. My task assignment email also had multiple field values, workflow variables as well as hyperlink to task URL (pic below)

While it worked perfectly fine in the beginning, at some point, I think the custom links/variables must have failed notification step. Long story short, I cleared the email body and ran my workflow and task assignment notification for the parallel block worked again.

Now I have to update the mail body.

Glad the issue is resolved now, but would appreciate understanding why it failed to begin with. (Malformed URL?! Rogue character in copy paste?!)Any ideas?