AnsweredAssumed Answered

Workflow Exchange Connector Error

Question asked by borisj on Jul 22, 2015
Latest reply on Jul 27, 2015 by emily.billing@nintex.com

Hi,

 

Environment: WIndows 2008 R2, NW 2013 3.1.30, Exchange 2013 CU8

 

I installed the ECS on Exchange (single machine install, no other applications) as per the PDF and everything seems in order. When I try using EmailProvisioning.asmx I get:

 

Error provisioning an email box for the specified user. Provisioning user on Exchange 2010 failed. Check the event logs on the Exchange 2010 server to determine the cause.

 

The event log entry is:

 

 

System.Management.Automation.CmdletInvocationException: Could not load file or assembly 'Microsoft.Exchange.Diagnostics, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Exchange.Diagnostics, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

 

   at Microsoft.Exchange.ProvisioningAgent.AdminLogAgentClassFactory.GetCmdletHandler(String cmdletName)

 

   at Microsoft.Exchange.Provisioning.ProvisioningBroker.GetProvisioningHandlers(Task task)

 

   at Microsoft.Exchange.Provisioning.ProvisioningLayer.GetProvisioningHandlersImpl(Task task)

 

   at Microsoft.Exchange.Provisioning.ProvisioningLayer.GetProvisioningHandlers(Task task)

 

   at Microsoft.Exchange.Configuration.Tasks.Task.<BeginProcessing>b__4()

 

   at Microsoft.Exchange.Configuration.Tasks.Task.InvokeNonRetryableFunc(Action func, Boolean terminatePipelineIfFailed)

 

   at Microsoft.Exchange.Configuration.Tasks.Task.ProcessTaskStage(TaskStage taskStage, Action initFunc, Action mainFunc, Action completeFunc)

 

   at Microsoft.Exchange.Configuration.Tasks.Task.BeginProcessing()

 

   at System.Management.Automation.Cmdlet.DoBeginProcessing()

 

   at System.Management.Automation.CommandProcessorBase.DoBegin()

 

   --- End of inner exception stack trace ---

 

   at System.Management.Automation.Runspaces.PipelineBase.Invoke(IEnumerable input)

 

   at Nintex.Workflow.ExchangeConnectorService2007.EMS.MailboxEnableWithPowerShell(String theDatabase, String theIdentity, String emailAlias, String powerShellSnapin)

 

mailboxPath: Mailbox Database 1638351060

 

user: test.user

 

I get the same result if I try running the web service directly from the web page.

 

Using the same parameters with Enable-Mailbox works fine (running as the same account as the AppPool used for the ECS directory).

 

I think its probably more of an issue with my Exchange than ECS but I was hoping someone may have already worked through something similar. Googling has not turned up anything helpful so far.

 

Regards

 

Boris

Outcomes