AnsweredAssumed Answered

Multi-Lookup to Variable Error: Coercion Failed: Unable to transform the input lookup data into the requested type

Question asked by markuden on Jun 24, 2015
Latest reply on Jun 25, 2015 by markuden

Hi!

 

I'm using SharePoint 2010 and Nintex Workflow 2010. I have a People list with a lookup to a second list of Groups. Each person can belong to one or more groups, so it's a multi-selection lookup.

 

I want to get the values of the lookup field into a workflow variable. This works if there are more than one group selected, but if only one group is selected it fails with the error "Coercion Failed: Unable to transform the input lookup data into the requested type."

 

I've tried various methods of getting this data into a variable, but I always get the same error where only one group is selected.

  1. "Set a variable" action with "Single line of text" variable.
  2. "Set a variable" action with "Multiple lines of text" variable.
  3. "Build string" action.
  4. "Query list" action filtered for ID of current item. This works when I use "Run Now", but not when the workflow operates.

 

Strangely, the workflow looks like it's completed according to the Nintex Workflow Progress page (i.e. all the action boxes are green), but the workflow status is "Error". Also, if I "Log in history list" the variable contents, they appear correct.

 

The following thread concerns a similar error, but is for setting a lookup field rather than just extracting its contents. The specified item was not found.

 

I'm making no progress on this. Any ideas, anyone?

 

Thanks,

 

Mark

Outcomes