AnsweredAssumed Answered

Parent Workflow Instance Error After Workflow Data Purge

Question asked by rick_pereira@shi.com on Apr 15, 2015
Latest reply on Apr 17, 2015 by rick_pereira@shi.com

Hello,

 

I've run into an issue and I am hoping to get some assistance/direction.  Here it goes:

 

Nintex Workflow 2010 2.4.2.0

SharePoint Server 2010

 

Yesterday morning I ran two purges using the Nintex Workflow Management > Purge workflow data option in Central Administration.  The first purge was for deleting workflow instances "Where the list or library has been deleted" which deleted approximately 7k entries and the second was using a custom filter with criteria "Last activity is before" (date used 6/1/2012) which deleted approximately 100k entries.

 

The issue I'm experiencing now is that workflows that were in a running state on a few lists are now starting to error out with an error mentioning missing a parent workflow instance for that workflow.  Seems as though these got removed somehow, likely with the "Where the list or library has been deleted" option, but why??.  In looking up the missing workflow instance ID in SQL Management Studio on the SQL Server where the Nintex Workflow Database resides, it is indeed missing from the database, and it exists in a backup taken of that database from the previous night.

 

Now how to fix this?  If I restore the backed up version of the Nintex Workflow DB, I will lose all of the user data for workflows started yesterday.  I have a support case opened for this issue but the response times are horrendous and the technician responded to an older email requesting more information after I had already sent a subsequent email to my original one with updated information.

 

I'm located in the US (EST) and was told by the UK office this morning (US office still closed) that the technician assigned to my case is in Australia, which is not very helpful given the drastic time zone difference.

 

Please help!

 

Regards,

Rick

Outcomes