AnsweredAssumed Answered

Writing to Oracle Database using the Execute SQL action

Question asked by jovix on Feb 18, 2015
Latest reply on Feb 20, 2015 by emily.billing@nintex.com

I need to create a workflow that will write some information to an Oracle 11g table. I am having an extremely difficult time simply connecting to the database from within the Nintex Execute SQL action.

 

Here is what I've done so far...

I have successfully downloaded and installed the Oracle 11g 64-bit client on my Web Front End. I know the client installation was successful because I was able to setup my TNSNames.ora file and by using SQLPlus, I am able to perform CRUD operations on the table I need to write to.

I have also used the Connection String Tester I found at Vadim Tabakman's blog here --> Connection String Tester - Vadim Tabakman

Using the tester I was able to once again connect and read from the Oracle table verifying my Connection String was correct.

 

Now here is my problem. When I fire up Nintex and use the Execute SQL, I am getting different error messages depending on the client that I have installed. I've tried several clients and several combinations and while I am able to get the connection working with SQLPlus and the Connection String Tester, I have not been able to connect from within the Nintex Action.

 

 

I have done the following:

  1. Installed 64bit Oracle client, getting this error: "BadImageFormatException. This will occur when running in 64 bit mode with the 32 bit Oracle client components installed"
  2. Installed 32bit Oracle client, getting an error that says "OracleClient requires Oracle client software version 8.1.7 or greater"
  3. Tried to install both clients, getting same error about requiring client version 8.1.7
  4. Found a blog post saying I should enable 32-Bit Applications to True for ASP.net in IIS but this brings down my whole site.
  5. Found a blog post saying I should install ODP.net (Oracle Data Provider) from ODAC (Oracle Data Access Components) but I'm back to requiring client version 8.7.1 error message.
  6. Found a blog post saying I should reset the security on the Oracle client home folder, I followed the steps but am still getting the same error message.

 

I am pulling my hair out on this one and could use your help. I forgot how many times I've installed and uninstalled the oracle clients. Has anyone here been able to successfully connect to an Oracle database?

I've spent 2 weeks on this and as I explained, everything works via SQLPlus and the connection string tester, but not from Nintex.

 

Thanks.

Outcomes