AnsweredAssumed Answered

Nintex web service connector: Index was out of range..

Question asked by aaronclausen on Feb 11, 2015
Latest reply on Feb 12, 2015 by aaronclausen

Hi Guys,

 

I am trying to make a simple SOAP service call using the drag and drop web service connector on a simple workflow.

 

The SOAP service I'm trying to call is a legitimate one that comes with a major fortune 500 product and it has an exposed WSDL file.

 

Nintex can successfully see the WSDL file and when I click "Test Connection" I get the result "OK".

I can also see Nintex successfully populate the input parameter fields and also it knows the structure of the result that I'm expected to receive in return.

 

But when I click "Execute" to do a live test, the "Results" text box simply populates with "Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index"

 

It doesn't seem to make any difference which values I use inside the two parameters.

I can also remove the parameters completely from the SOAP request and I still get the same result.

 

Any ideas on this error? Is it being thrown by the Nintex SOAP parser itself? It looks like a generic .NET error coming from Nintex/SharePoint, rather than from the web service I'm calling itself.

 

Many thanks!

Outcomes