AnsweredAssumed Answered

Could not publish workflow because Type or NameSpace doesn't exist

Question asked by rangelin on Aug 3, 2018

This is not so much a question as a post that I hope will be helpful to other people here. 

 

I had an issue where I was unable to publish my workflow to a list on a new SharePoint Web Application. I had gone through all the appropriate steps to activate Nintex Workflow and Forms. I could create a Nintex Workflow and SAVE it without any issues. However when I tried to publish the workflow I would get the following error:

soap:ServerServer was unable to process request. ---> Failed to publish workflow: <Error>

<ComplierError Line="0" Column="26" Text="The type or namespace name 'Activites' does not exist in the namespace 'Nintex.Workflow' (are you missing an assembly reference?)"/>

<ComplierError Line="19" Column="26" Text="The type or namespace name 'Activites' does not exist in the namespace 'Nintex.Workflow' (are you missing an assembly reference?)"/>

<ComplierError Line="18" Column="26" Text="The type or namespace name 'Activites' does not exist in the namespace 'Nintex.Workflow' (are you missing an assembly reference?)"/>

<ComplierError Line="17" Column="26" Text="The type or namespace name 'Activites' does not exist in the namespace 'Nintex.Workflow' (are you missing an assembly reference?)"/>

 

I did a search online and found some helpful article that still did not work such as: https://support.nintex.com/SharePoint/Workflow/Error_%22The_type_or_namespace_name_ 

where it suggests going to Central Admin > Nintex Workflow > Web Application Activation. Make sure you've selected the webapplication you want to publish on from the dropdown.

 

I opened a support ticket and sent them the logs and my web.config for the IIS site but they didn't find anything that would point to the issue. 

 

I was able to finally fix this by complete deactivating everything on the site collection for Nintex Form and Workflow. 

 

1. I went to the Site Settings and disabled everything to do with Nintex Forms and Workflow, then…

2. I went to the Site Collection settings and disabled everything to do with Nintex Forms and Workflow, then…

3. I went to Central Administration and disabled Nintex Forms for the Web Application, then…

4. I went to Nintex Administration and deactivated Nintex there, then.

5. I went and loaded the site in a browser and it took a while to process and load, then…

6. After that I went in reverse and re-activated everything for Nintex Forms and Workflow according to the documentation for activating Nintex Form and Workflow, then…

7. I went back and loaded the site in a browser and it again took a while to process and load, then...

8. I went back to my list on the site and created a workflow and was able to successfully publish the workflow!

 

I hope that this will be helpful if anyone else has an error similar to this.

Outcomes