AnsweredAssumed Answered

Workflow Error Potentially Due to Multiple Active Directory Accounts Under Same Name

Question asked by jotunda on May 29, 2018
Latest reply on Jun 5, 2018 by jotunda

My company allows for several user accounts to exist under the same name. Each employee gets a primary account in Active Directory (AD), and users who require additional accounts receive service accounts, which have different user ids but still show up when the account owner is searched for in People lookup fields. All primary accounts have an email address, but not all of the service accounts have email addresses. For example, John Doe has two accounts, a primary account (ID = 'userJohnDoe', First Name = 'John', Last Name = 'Doe', Email = 'johndoe@nintex.com')  and a service account (ID = 'serviceAccountJohnDoe', First Name = 'John', Last Name = 'Doe', Email = '').

 

I'm experiencing an error in an Update Item action in a Nintex Workflow in SharePoint 2013 where an Initiator's user id is removed from one People column and added to another; there can be multiple users in both columns. This workflow always errors out when users who have multiple AD accounts initiate the workflow, but never errors out for users who do not have multiple AD accounts.

 

These are the errors messages:

 

Other info:

  • The 'Update Item' action is not highlighted in yellow on the Workflow Summary page for any of these errors. Normally, the action is highlighted yellow where the error occurs.
  • Our company recently converted all user accounts to O365 for an upcoming migration to Outlook O365

 

Things we have tried, but received the same error messages for:

  • Added Commit pending changes actions directly before and after the Update Item action
  • Removing the user (e.g. John Doe) from the internal user SharePoint list, having the user retry the workflow after so that their username and info are pulled from AD.
  • We tried to recreate the error by altering the Workflow a bit. We hard-coded 'John Doe's' primary account where the 'Initiator' variable was used and could not get the error to be thrown again.
  • Republishing the workflow

 

Has anyone experienced this before / has any idea how to fix this issue?

Outcomes