AnsweredAssumed Answered

StartWorkflowOnListItem 404 The requested resource is not found

Question asked by dgoodridge on Apr 4, 2018
Latest reply on Apr 11, 2018 by emha

I'm having an issue that's driving me nuts. I have used StartWorkflowOnListItem I don't know how many times, but for some reason I can't get it to work in this instance. 

 

I have a scheduled site workflow that queries a list for items who's date column equals today. The resulting IDs are stored in a collection. Then I run a For Each loop on the collection, storing the item ID in a number variable. The Call Web Service action is configured for NintexWorkflow/Workflow.asmx - StartWorkflowOnListItem. I pass the item ID from collection (I've checked the variable and it's coming across as a number), the list name, Workflow name, and no association data. 

 

When I "Run Now" it works fine. When the action is triggered during the scheduled site workflow I get error text "HTTP Error 404. The requested resource is not found." I have tried configuring the action with a hard-coded item ID value, but same results. I even tried recreating the list and site workflow to no avail. I am site collection administrator, as well as having rights over the web application. 

 

Can someone please explain what is going on?!?!?!

Outcomes