AnsweredAssumed Answered

Workflow Web Request returning The request was aborted: Could not create SSL/TLS secure channel.

Question asked by marekan on Jan 18, 2018
Latest reply on Feb 25, 2018 by marekan

Hi all,

 

anyone ever done web request to Cisco Identity Services Engine

 

https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/api_ref_guide/api_ref_book/ise_api_ref_guest.html

 

?

 

I have web request in the workflow which is supposed to create the user account in Cisco Guest portal. The web request works in SOAPUI 5.4.0 on my computer. The account is created successfully (pre-emptive authentication is needed to be used).

 

But in the workflow it returns The request was aborted: Could not create SSL/TLS secure channel error.

 

According to the documentation on above web site you need to use Basic authorization.

 

The web request action is set up as follows

 

 

It is basically the same way as in SOAPUI tool. I have tried the following none of which has helped:

  1. Add header Authorization: Basic UserName:Password as per the documentation in above link
  2. Removed the content-type header since it is already in Content type mandatory field of the action.
  3. Removed username and password from the action fields and kept it just in Authorization header

 

I have tried to open the request url directly in IE on WFE server and after entering the UserName and Password into the pop up window it authenticated me normally.

 

Any idea what am I missing here please?

 

Many thanx

 

Jan

Outcomes