AnsweredAssumed Answered

O365 SharePoint Nintex Workflow erroring out today - Access is Denied.

Question asked by thoang858 on Nov 29, 2017
Latest reply on Mar 6, 2018 by thoang858

Greetings,

 

I have a Nintex workflow running on O365 list that was working for months and all of a sudden, it stopped working today and errors out with access is denied. Worked with the site owners to confirm that permissions has not be altered and verified the permissions myself.

 

Background Information - The site is opened up to everyone with Read access, however, the list and Workflow Tasks list have broken inheritance where the security group that contains every users in the organization is added with Contribute access. 

 

Troubleshooting steps -

  1. Ensured that WORKFLOWS CAN USE APP PERMISSIONS site feature was enabled.
  2. Verified that users were indeed able to create/add new items to the list.
  3. Re-initiated the workflow by clicking the RETRY NOW link within the workflow status.

 

In order to get the workflow to work, I temporary elevated every users' access as contributor or added the security group to the Members SharePoint Group which I don't think would be necessary. I have worked with the on-prem version of Nintex Workflow and it has always worked with list that had unique permissions.

 

Has anyone recently encountered a similar issue? Any suggestions or feedback would be greatly appreciated.

 

Thanks.

Outcomes