AnsweredAssumed Answered

Forms task data not saved to task list

Question asked by najdo on Oct 16, 2017
Latest reply on May 22, 2018 by najdo

Hello,

 

I've seem to have a problem with data not being saved to the task list when editing a task form using Nintex forms.

Little background:

I've created a process using Nintex Workflow that include multiple tasks. Each task requires some data to be filled in by the user and his approval. I've created for each kind of task a new content type, inheriting from the default workflow task. I've created my workflow and tested it using the default form experience in SharePoint. So far so good.

Now I'm editing the forms so that the contain the company logo and some other theme. Now I'm having some trouble with some fields whose data is not being saved to the task list. 

 

In the image you will see 3 tasks. The first item is created by adding a task action in Nintex workflow and not editing the form using Nintex forms. The data for the field 'Deadline agentschap(pen)' (which is a date field) is being saved to the task list.

The following 2 items are tasks that are edited with Nintex Forms (in my workflow). You see cleary that they are edited using Nintex forms by looking at the content type (last column in the screenshot). Now the strange part is that another field 'Behandeling boodschap' (multiple lines of text) it's data is being saved to the list.

When I open the second and 3th item I see the correct date being shown in the form. So apparently my date field data is saved somewhere but not in the task list.

 

I add the field to my form using the following method: selecting the field beneath the 'Task columns' menu, dragging & dropping it on my form. I've checked the 'connected to' field and that seems correct.

I can save the data by connecting my control to a workflow variable. But I've rather see it being saved to the task list, like the other columns.

 

Things I have tried:

- Setting the date field to required

- Setting the date to optional

- Using the Nintex responsive form editor

- Tried changing the OK button to save or save & submit

- Tried using a task process instead of 'assign a task' in Nintex workflow

 

Thanks in regards,

Davy

Outcomes