AnsweredAssumed Answered

Calculated field is always blank for Lookup function

Question asked by mattmallory on Jun 28, 2017
Latest reply on Jun 29, 2017 by emha

I have an issue that has been killing for for a couple of days now.

 

I have a list with a form that I have modified with Nintex Forms 2013. In my form I have a List Lookup field and Calculated field, the calculated field is using the Lookup Function to provide another field value based on the result of the List Lookup selection. I have named the ListLookup field properly and everything seems fine. 

 

The problem is that regardless of what I select from the List Lookup field, my calculated field is always blank. I have tried changing field names in the calculation but they always return blank. I can't seem to find a good method for troubleshooting what may be going wrong here. I have tried looking at the IE developer panel and it shows the query firing, but doesn't indicate anything about results. 

 

My gut is telling me that this has to do with the columns that have been setup in the list, apparently there were some content types on the list at one point and as a result the internal name of the columns are numbered (in my case it is "Acronym0" instead of the friendly name of "Acronym") My guess it is that it trying to pull from the original column, which would be blank, but I can't find anything about passing the Internal column name (and I have tried to just use it but get the same results) - This could also be a red herring too. 

 

Anyone have any other thoughts as to what may be the problem here, or other methods that I can use to troubleshoot and get to the root cause? 

 

Thanks

 

EDIT: Here is a screenshot of the Lookup formula, ltTerm is my named control for the List Lookup field. 

Lookup Formula Configuration

 

EDIT: Here is a screenshot of my List Lookup configuration settings. 

List Lookup Control Configuration

Outcomes