AnsweredAssumed Answered

Approve Flexitask from InfoPath 2013

Question asked by prasaddjoshi@outlook.com on Jun 6, 2017
Latest reply on Sep 21, 2017 by fhunth

Hi There,

 

We are using SharePoint 2013 onpremise with Nintex and trying to approve a workflow Flexitask from Infopath 2013. 

For approving the workflow task from InfoPath we are using below steps,

https://askmanisha.wordpress.com/2013/07/19/clubbing-infopath-form-nintex-approval-form/

 

Environment : SharePoint 2013, InfoPath 2013, Nintex 2013

WebSerive used for approval : https://WebURL/_vti_bin/NintexWorkflow/Workflow.asmx

Web Method Tried: "ProcessFlexiTaskResponse2″ & ProcessFlexiTaskResponse″ 

 

We are not using the GetRunningWorkflowTasksForListItem as of now and manually passing the TaskID from InfoPath form to approve the task.

 

When we are trying to approve the task on a button click we are getting an exception as below,

 

Exception  System.Net.WebException: The remote server returned an error: (401) Unauthorized.     at System.Net.HttpWebRequest.GetResponse()     at Microsoft.Office.InfoPath.Server.SolutionLifetime.WebServiceHelper.GetResponseHelper(WebRequest request, DataAdapterCredentials credentials, Stopwatch timer, ExecWebRequestExceptionState state, String adapterName, Boolean isQuery)     at Microsoft.Office.InfoPath.Server.SolutionLifetime.WebServiceHelper.ExecWebRequestSync(XPathNavigator inputSubDOM, Boolean[] inputUseDataset, XPathNavigator resultsSubDOM, Boolean resultUseDataset, XPathNavigator errorsSubDOM, Uri serviceUrl, Uri soapAction, Int64 timeOutMillisec, DataAdapter adapter, Document document, DataAdapterCredentials credentials, Boolean useDcl, Boolean useProxy, Boolean useSelf) StackTrace:  at M... 5a2cf99d-981b-5037-3c0d-5d86265c6259

 

We tried by adding a Authentication tag in UDCX file with a secure store application but still getting the same exception.

 

Can someone help to identify the issue here ?

 

Thanks

Outcomes