AnsweredAssumed Answered

Problem with workflow import/export: The workflow could not update the item

Question asked by andrew.x.childress@us.tel.com on May 8, 2017
Latest reply on May 10, 2017 by andrew.x.childress@us.tel.com

I have a complex workflow (2013) with a state machine and multiple Flexi tasks, and I want to copy it from one list to another list on the same site.  The second list is a copy of the first, created using the SharePoint list gallery.  The copied workflow works until it gets to either a Flexi task or a Commit pending changes action, at which point it breaks down and sends two error messages, one that just says "an error has occurred" and another that says "The workflow could not update the item, possibly because one or more columns for the item require a different type of information."

 

I tried resetting the Flexi task and even replacing it with a new Flexi task before discovering the Commit pending changes produced the exact same error.  My next step is going to be trying to recreate the list from scratch instead of the from the SharePoint list gallery and see if the error persists.

 

Has anyone encountered this before?  Feels like a Nintex bug.

Outcomes