AnsweredAssumed Answered

Update Item Properties in Document Library Fails

Question asked by bcasey on Feb 24, 2017
Latest reply on Feb 27, 2017 by bcasey

I am using WF to take a list item from a custom list and create a Word document (using content controls).  Then, I convert the Word doc to a PDF and save it to a Document Library, along with any attachments to the list item.  Also, I then update some fields for the newly added docs in the library.

 

All this is working great except that I get errors when the WF tries to update the PDF document properties.  The attachments are generated, renamed, and added to doc library fine, and all their properties are updated via Update Item with no issues.

 

Then, I go to update the properties of the PDF form that was added, and I get an error and fields remain blank.  You can see ItemID below is filled in for attachments, but not for the PDFs / forms.

 

In my failing Update Item action, I have set URL Path to the same variable that is used when creating the PDF in the doc library.  In my log, I can see and verify that this URL is correct, and if I paste it into a new browser window, it even opens the document.  I've also tried setting URL path to the value of the URL directly, still no update.

 

It's strange that this works fine for the attachments that are added to library, but errors on the PDF that was added.  Some attachments are PDFs as well, and still work fine.

Outcomes