renatois

State Machine dehydration error

Discussion created by renatois on Jan 13, 2017

Hi, I have a state machine Nintex workflow that when it changes state it goes on error, weird because it seems to continue working but it doesn't work properly and stays blocked (see history below).

 

The question is:

 

- I found an article that can maybe help with this problem but I is there any impact of this procedure to other workflows running in the server?

 

SOURCE : https://support.microsoft.com/en-us/kb/2674684
Resolution
Method 1:
Locate one Web Front End server which has Web Application service running, run the following PowerShell command to copy workflow-related configuration from the web.config to the configuration database so it will be available from every server in the Farm.
• $webapp = Get-SPWebApplication -identity http://<web app name>
• $webapp.UpdateWorkflowConfigurationSetttings()
Method 2:
Start the Web Application Service on all servers that have the Workflow Timer Service running.
Method 3:
Disable the Workflow Timer Service on servers that are not running the Web Application service.

 

Workflow History
The following events have occurred in this workflow.

[ ]

Date Occurred

  

Event Type

  

User ID

  

Description

  

Outcome

  

[ ]

08/12/2016 13:57

Comment

Ok

[ ]

08/12/2016 13:57

Comment

Ok

[ ]

08/12/2016 13:57

Comment

Ok

[ ]

08/12/2016 13:57

Comment

System Account

INitialisation : Next step = Opener

[ ]

08/12/2016 14:00

Error

System Account

CR-Workflow failed to run.

[ ]

08/12/2016 14:01

Comment

Ok

[ ]

08/12/2016 14:01

Comment

Ok

[ ]

08/12/2016 14:01

Comment

Ok

 Thanks!

Renato

Outcomes