AnsweredAssumed Answered

Hide Panel in a Nintex Form when "New Mode" doesn't work

Question asked by andreapasutti on Dec 2, 2016
Latest reply on Dec 29, 2016 by amolvaidya

I have a form that gets filled out by Initiator. There are panels in the form that should only be visible to Preparer 1 so that Initiator doesn't fill them out. The problem is that when the form is entered into the library, the workflow hasn't run yet, so the Preparer 1 field hasn't been populated yet (workflow looks to a Business list to find Preparer 1 associated with that business because I can't look up a People Picker column).

 

Hiding the panel based on "New Mode" doesn't work, even though a document is entered into the library by the Initiator and it is a new form being filled out. Hiding based on "Edit Mode" works, but then it is hidden from Preparer 1 as well.

 

I've thought about hiding the panel based on a SharePoint permission group, but it doesn't appear that this is an option inside a form.

 

I tried setting a form variable to a specific user,  but that didn't work. Perhaps I was doing that wrong. Regardless, I don't want to get into hard coding individuals, even though the Initiator is always the same person. I'd like to keep my rules based on flexible things like permission groups or columns.

 

So I want to hide a panel in New Mode and based on a people-picker field that gets updated later via workflow. How do I do that if "New Mode" doesn't work and how do I write a rule to hide based on the value in the Preparer 1 people-picker column?

 

Any suggestions?

Outcomes