AnsweredAssumed Answered

Is it possible for a workflow to become corrupted?

Question asked by matt_shaw on Sep 27, 2016
Latest reply on Sep 28, 2016 by burkslm

I have a fairly complex workflow that I was working on that suddenly wouldn't publish (kept getting a pop-up that said "undefined" and afterwards it wouldn't let me publish.

 

I eventually ended up exporting the workflow, deleting the original and reloading it under a different name.  This has somewhat worked - I occasionally get the "undefined" error but in general I can updated the workflow.

 

The problem now though, is that whenever I run the workflow I get the error notification "Coercion Failed: Unable to transform the input lookup data into the requested type." whenever I run the workflow.  It's not related to any particular section or item.  I've tried running the workflow dozens of times over the past few days with various sections disabled.  Doesn't matter if I have lookup functions enabled or not, this error occurs.

 

This is a last ditch effort for advice before scrapping the entire project.  Any ideas anyone?

Outcomes