AnsweredAssumed Answered

Migrating from SharePoint 2013 to SharePoint 2016 with Nintex Workflows

Question asked by christopher.schuh on Aug 12, 2016
Latest reply on May 15, 2018 by krishnachaluvadi

We are currently testing a migration from SharePoint 2013 to SharePoint 2016.  We have a new SharePoint 2016 server.  We backed up our current content database on our 2013 farm and ran Test-SPContentDatabase.  It stated that it was missing the Nintex Workflows and Forms so I installed Nintex Workflow for 2016 on the new SharePoint 2016 farm.  When I re-ran Test-SPContentDatabase, I received the following errors:

 

Category        : MissingFeature

Error           : True

UpgradeBlocking : False

Message         : Database [ContentDB] has reference(s) to a missing feature: Id = [IDNUMNBER], Name = [Nintex Workflow 2013 Reporting Web Parts], Description = [Allows the Nintex Workflow Enterprise reporting web parts to be added to sites in this site collection.], Install Location   = [NintexWorkflowEnterpriseWebParts].

 

Category        : MissingSetupFile

Error           : True

UpgradeBlocking : False

Message         : File [Features\NintexWorkflowEnterpriseWeb\NintexWorkflowReportPages\home.aspx] is referenced [4] times in the database [ContentDB], but is not installed on the current farm. Please install any feature/solution which contains this file.

Remedy          : One or more setup files are referenced in the database [ContentDB], but are not installed on the current farm. Please install any feature or solution which contains these files.

 

Category        : MissingSetupFile
Error           : True
UpgradeBlocking : False
Message         : File [Features\NintexWorkflowEnterpriseWebParts\WebParts\WorkflowChartViewer.webpart] is referenced [1] times in the database [ContentDB], but is not installed on the current farm. Please install any feature/solution which contains this file.
Remedy          : One or more setup files are referenced in the database [ContentDB], but are not installed on the current farm. Please install any feature or solution which contains these files.

 

Category        : MissingSetupFile
Error           : True
UpgradeBlocking : False
Message         : File [Features\NintexWorkflowEnterpriseWebParts\WebParts\WorkflowReportViewer.webpart] is referenced [1] times in the database [ContentDB], but is not installed on the current farm. Please install any feature/solution which contains this file.
Remedy          : One or more setup files are referenced in the database [ContentDB], but are not installed on the current farm. Please install any feature or solution which contains these files.

 

Category        : MissingWebPart

Error           : True

UpgradeBlocking : False

Message         : WebPart class [IDNUMNBER] (class [Nintex.Workflow.ServerControls.WebParts.ReportList] from assembly [Nintex.Workflow.ServerControls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=913f6bae0ca5ae12]) is referenced [4] times in the database [ContentDB], but is not installed on the current farm. Please install any feature/solution which contains this web part.

Remedy          : One or more web parts are referenced in the database [ContentDB], but are not installed on the current farm. Please install any feature or solution which contains these web parts.

 

Question: How do I go about installing these features from Nintex 2016 as I just used the default installation or do I not need to worry about these errors when I attach my 2013 content database to my 2016 farm?  Please advise.

Outcomes