shuttjo

Workflow error when using site templates - Log History action fixes it?

Discussion created by shuttjo on Aug 8, 2016
Latest reply on Aug 10, 2016 by cazza162

Someone suggested I bring this up to support. I do not have my companies product key info to open a ticket so I am posting in here. I recently created a SP13 site that had about 10 lists and several workflows on it. Everything worked great. I needed to replicate this site across approx. 30 other subsites, with the same workflows. I saved this site template with content in order to bring over the workflows. This seemed to do exactly that and all of my workflows for these new subsite were working, except for 1. This one kept erroring out at my update item action. Nothing changed on these lists or workflows so I was baffled. Cassy Freeman suggested that I create the site template without content, and manually import the workflows from my hard drive. Same result. Cassy then suggested that maybe I should add a "Log in History" action to see what results I am getting back. All I did was add this log in history action, after my update item action, and voila, all of a sudden the workflow ran like it was supposed to. I am very confused, and baffled, as to why a log in history action would correct this issue.

 

Is this a known behavior when using imported list workflows from other site templates?

Outcomes