AnsweredAssumed Answered

Lookup Columns & Coersion Errors

Question asked by kholleback on Jul 22, 2016
Latest reply on Feb 28, 2017 by cazza162

Nintex seems to do a nice job of hiding data types from the end user.  When debugging coersion errors however, the debugging of workflows can be quite daunting.  Clearly there is a data type mismatch between what the workflow is expecting to feed into the Update Item call and what I've provided.

 

Fwiw, I've already reviewed a few other posts on coersion errors though not yet found a solution. 

 

Scenario:  2 lists, List 1= Entities which includes a lookup column to List 2=Clients.  When the workflow creates a new Client and new Entity, I first create the new client and store the ID, then I create the entity and store the ID, then I attempt to Update the Entity with Client details.  Creating each list item works correctly, but doing the update on the lookup column isn't working and I feel like I've tried virtually every scenario.

 

wfOwner1 is a text variable

wfNewEntityId is list ID

 

I also tried doing a Query on the Client List, storing the Client Name in a text variable and then attempted to update Client1 like this: 

 

The challenge with this scenario is that Client1_TEXT only gives return type options for Integer values.  I selected As Integer (default), but wouldn't expect this one to work since the field is text and the list is expecting a text value.

Both scenarios give the same coersion error with no further debugging help.

 

Anyone know if Nintex has documentation on data type conversions related topics and lookup columns? I haven't found much helpful documentation.  I've checked Vadim's site as well, but not tracked anything down with enough depth to help on the coersion errors. 

Outcomes