I just stumbled over the runtime function lookup. Why needs this display names for list- and column-names instead of internal names?!
This makes absolutely no sense because as soon someone renames a column or a list, it doesn't work any longer.
Even more worse is the fact that if your website supports multilingualism and a list or column has naturally another displayname than in english, the form crashes because the lookup-function doesn't find the list or column.
In my case, two lists "aTranslation" and "bTranslation" were created and renamed afterwards both to "Translation". So the lookup-function uses the first list, it find's with this name.
This makes the function absolutely useless. Is there an alternative for this?
Greetings from Nuremberg
I think, it would be useful to enhance the code by checking if listName is a GUID and if so, call .getById(self.listName). So the list would be obvious.