AnsweredAssumed Answered

Issue with Execute SQL and workflow constant for connection string

Question asked by gadams on Aug 10, 2014
Latest reply on Oct 12, 2017 by sebasnn86

Hi,

I haven't tried to use this feature before so I'm not sure that I'm doing it right or if this is an issue.

 

Nintex Workflow 2013 (build: 3.0.7.0)

 

The DB connection string is: Server=SQL01;Database=MyDBName;User Id=USERNAME;Password=MYPASSWORD;

(I am using a standard SQL user account not a windows credential)

 

I have confirmed that the string works. Firstly by using the connection string tool from Vadim's blog site

Secondly if I add an Execute SQL action and paste in the connection string. Then use the run now test I am able to use the test connection button successfully and also run a simple select statement correctly.

 

What does not work for me.

I have created two workflow constants at the farm level

1) a string with the sensitive constant button ticked

2) a secure string

 

Both constants have been secured to a specific group of users who are designing the workflows. (Basically my admin account for this testing).

I have pasted in the above DB connection string into the values for these constants.

 

When I run the test using either of these constants, the run now fails.

I receive the following error message.

 

The execution returned an unexpected error.

Format of the initialization string does not conform to specification starting at index 0.

 

Can anyone confirm the correct way to use this?

Or is this a bug?

 

Thanks,

Gavin

Outcomes