AnsweredAssumed Answered

Disabled WF Timer Service on App Server ... issues creating task list ensue

Question asked by vacoder on Jul 9, 2016

I finally have my QA farm permissioned out correctly and my timer jobs are no long getting hosed up every 5 minutes, workflows are processing and I can finally get a good nights sleep. I stopped the WF Timer Service on the App server, along with the web application service because that's the best practice, for us anyway, and then I resolved some permission issues. I was motivated to do this because when I created a HNSC site via powershell on the now workflow timer service-less application server I was no long seeing the Workflow Task content type on the Task list that gets created when adding a workflow to a custom list. I need this back!

Here is what I'm now seeing on the task list after stopping the services:

 

 

What I see on sites that I set up prior to stopping the services is:

 

 

When I go into the 'Add from existing site content types' the Workflow Task is not available to select. I should note as well that our third party solution that uses Nintex adds 3 other custom Task content types to these lists but these too are missing when the site is initially created. I can however add them manually using the method below.

 

Additionally, when I go to select a list to associate on the assign task action in the workflow I am missing some that derive from the Workflow Task type (2010 type of course).

 

In my setup script I create an instance of the WorkflowManager and remove a few default web parts from the home page that get put there when a team site is created. This always worked on the app server but not after turning off these 2 services. If I run the script on the WFE where the timer service is running the web parts are removed correctly but the issues with the missing 'Workflow Task' type persists.

 

I reinstalled Nintex Workflow to the farm, running it on the app server as always and then I repaired the third party workflow solution that depends on Nintex. I then ran the powershell to create a site on the App server (as always), using the setup account, and the issue persists. The thing is our workflows are processing better than ever now so I'd really like to get this working.

 

Any idea on how to get this base content type for SharePoint back in the mix?

Outcomes