AnsweredAssumed Answered

Nintex licensed for 1 WFE server with SP workflow Timer Service running on 2 servers

Question asked by vacoder on Jul 6, 2016
Latest reply on Jul 7, 2016 by jackgelo

We have 1 WFE, 1 APP and another APP Server dedicated to SSRS. We have a license for our web front end. I switched on the SP Foundation Workflow Timer Service on our App server but have since turned it off since there were an abundant number of attempts to connect to the Nintex_Content Database...like over 8000 in a 5 minutes and this would go on all day. These were all logged under the Database area of the Nintex Workflow 2013 Category:

 

Opening connection : Data Source=OURDB;Initial Catalog=Nintex_Config;Integrated Security=True (Build:3180)

 

These would end with:

 

Error establishing database connection.: System.Security.SecurityException: Access is denied.       at System.Security.Principal.WindowsImpersonationContext.Undo()     at Nintex.Workflow.Administration.ConfigurationDatabase.OpenConfigDataBase()     at Nintex.Workflow.Administration.Database.ExecuteReader(SqlCommand command, CommandBehavior behavior)  The Zone of the assembly that failed was:  MyComputer (Build:3180)

 

Once I turned Workflow Timer Service off on the APP server these stopped. I also have Central Administration running on this App Server (I've got super low budget  so..it is what it is for now).

 

Here is my hunch on what's happening and how to move forward. Because I am running the MS Foundation Web Application service on the APP server Nintex considers it a WFE and puts a restriction on connection to a content database. In order to run to the workflow timer service on the app server I would need to turn off the web app service. This would keep al requests coming from the wfe and give my another server to run the workflow timer service on and offload some of the burden from my WFE. Am I barking up the wrong tree here?

 

Thanks

Outcomes