AnsweredAssumed Answered

powershell.exe error when upgrading/installing.

Question asked by erik on May 3, 2016
Latest reply on May 3, 2016 by frank.field@nintex.com

Had an issue upgrading my dev environment. When I ran the nintex.install.exe to upgrade our installation from version  2.4.6.0 to version 2.4.8.0 and we tried to install (to test) nintex live for the first time, we kept getting error The term ‘powershell’ is not recognized as the name of a cmdlet, function.. etc.. then it would crash..

 

screenshot.jpg

 

and when I clicked on nintex live in central admin, I would see:

 

I opened a ticket with Nintex support and the person sent me the installation manual and then link to upgrade steps. None of which really helped.

https://community.nintex.com/servlet/JiveServlet/previewBody/1393-102-15-5552/InstallGuide-NWNF2010.pdf

https://community.nintex.com/docs/DOC-1151

 

After troubleshooting my own problem, I finally figured out that the reason why the install was failing. When I went into CMD and typed in powershell.. It gave me an error. So I added the location to powershell.exe in the windows path (in our case it was C:\Windows\System32\WindowsPowerShell\v1.0) and re-ran the installation EXE and then it worked without issues.

 

Hope this helps somebody.

Outcomes