AnsweredAssumed Answered

Assign-To-Do task not completing for days and days

Question asked by sivakumar on Jul 30, 2014
Latest reply on Aug 5, 2014 by darjackson86

Hi All,

I'm experiencing a huge delay in Assign-To-Do task(Not completing for days and days) in Nintex workflow 2010. Sometimes I get workflow failed to run on Assign-To-Do task.

 

Environment:

  • SharePoint 2010
  • Nintex Workflow 2010
  • Build Version: 2.3.10.0

 

I have a workflow it has assign to do task action and it is autocompleted by updating workflow task items through workflow as shown in the image.

Update item for workflow task and assign to do tasks are lies on parallel actions to achieve expected behavior.

Find the workflow design below:

reject.jpg

When the workflow runs assign to do task creates item in workflow task list and it is completed by update item. But assign to do task action doesn't complete at all.

 

Tried to trouble shoot:

  • Added commit pending actions before and after each actions to make sure all actions are committed and ensure there are no conflicts of batch process before move to next
  • Pointed the workflow to new workflow task list and checked
  • Pointed the workflow to new history list and checked
  • Earlier in DB I had around 80 million records in workflow progress table. Now I have deleted garbage data and reduced up to 10 Million
  • I have checked creating a small workflow to check the function whether assign to do task action is working there or not.
  • Purged all history list for the web application

 

No luck at all. Could you please advise on this to troubleshoot the issue?

Outcomes