AnsweredAssumed Answered

Coersion Failure Revisited - Unable to transform the input lookup data into the requested type

Question asked by thecarpe on Apr 28, 2016
Latest reply on Jun 6, 2016 by sharon

The previous question on this was assumed answered, but it actually wasn't answered.  I'm going to re-open the discussion.  Here is an overview of the issue as it exists in my context.

 

Setting: 2 lists. List A has a lookup column that references List B (Menu Item) and pulls in an additional field (Cost).  The List A shows it as Menu Item:Cost.  In both lists, the value is a number.

 

Workflow (list A - a meal scheduling list): Take the lookup in List B:Cost (which is a number that is the cost of a menu item - list B is just a plain menu, unit cost, vendor list), and convert it into a variable, which is also a number. Call it "Cost" (this is where the error occurs - tried to directly use the number, tried to create a variable, tried to use it as currency, tried to use it as a single line of text...same result: coersion failed). Multiply "Cost" by number of people in the meeting, store that value in variable "subtotal", update subtotal field with variable, etc, etc, with tax and total cost.

 

The problem is that the lookup (which has successfully worked for me in the past) cannot seem to take the additional field data (which is a number in this case) and make any sense of it in the destination list.  Seems so simple, but 28 errors later, I'm scratching my head - corrupted list?

Outcomes