AnsweredAssumed Answered

Issue passing associated data with StartWorkflow web service call

Question asked by murphybp2 Champion on Jul 28, 2014
Latest reply on Nov 24, 2014 by shyamshinde08

I have a list and a document library. On the list I have a workflow running where at a certain point I use a call web service action to call the StartWorkflow web service to start a workflow called "Approve Document" on the document library.  As part of this I want to pass a variable into the workflow to use for the approval comments. However I have not been able to successfully pass the variable.  The workflow starts and runs, but the variable is empty.  I've read the threads I could find on the old site, and tried every variation I could think of, but to no avail. 

 

Here is the SOAP for the StartWorkflow web service call.  I have a variable in the Approve Document workflow named "st_DocumentComments", and I have it marked to show on the start form.  I've tried using <associationData>  and even the default of <m:associationData>.  I've tried it with the "Encode inserted tokens" checked and unchecked.  I've tried every option I could think of, yet nothing works.  And I'm not getting any errors.  I'm hoping there is something simple I'm just overlooking that another pair of eyes could help with.  Anyone have any ideas?

 

 

<?xml version="1.0" encoding="utf-8"?>

<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:m="http://nintex.com">

  <soap:Header>

  </soap:Header>

  <soap:Body>

    <m:StartWorkflow>

      <m:fileUrl>{WorkflowVariable:st_DocumentUrl}</m:fileUrl>

      <m:workflowName>Approve Document</m:workflowName>

      <Data>

      <st_DocumentComments>{WorkflowVariable:st_Comments}</st_DocumentComments>

      </Data>

    </m:StartWorkflow>

  </soap:Body>

</soap:Envelope>

Outcomes