AnsweredAssumed Answered

Can't save workflow, config XML got stuck in check out state

Question asked by rszabo on Mar 31, 2016
Latest reply on Jan 3, 2017 by allan48728

I encountered an issue and I thought I share the solution. Maybe most of you already know.

  • The User tried to publish a new version of a workflow, but something went wrong...
    • Other SOAP error messages related to the issue:
      • soap:ServerServer was unable to process request. ---> [URLtoXML] can't be found on this Site.
      • soap:ServerServer was unable to process request. --> Exception of type 'Cobalt.ErrorException' was thrown.

  • After she reopened the workflow she get an error message: Exception of type: 'Cobalt.ErrorException" was thrown.

  • After a few try he could open the workflow, but when he tried to publish he got a SOAP error. (In a JS Alert popup)
    • SOAP Error message on Workflow Publish: soap:ServerServer was unable to process request. ---> The file [URLtoXMLpath] is checked out for editing by [USER NAME].

 

Root cause: Config XML got stuck in Check Out state. Like a normal document in a document library.

Solution:

  • Find the checked out XML file and click on name to open the local menu (you can see the green arrow icon)
  • Choose: Discard Check In

  • Open again your Workflow and Publish the correct version.

Outcomes