AnsweredAssumed Answered

"Create item" fails if Form type is Custom but no Start page is set

Question asked by lonesurvivor on Feb 4, 2016
Latest reply on Jul 6, 2016 by murphybp2

Hello everyone,

 

I think, we found a bug or did a fundamental mistake:

 

We created a very simple workflow that should just create an item in another list by starting the workflow on a list item.

The workflow action is wrapped inside an action set that should run as workflow owner.

 

This works fine as long as the form type in the workflow settings is set to Default.

 

If I try to change it to custom an remove the value in the start page field, the workflow fails with the following error: "The workflow could not update the item, possibly because one or more columns for the item require a different type of information." It doesn't matter, how starts the workflow. The error occurs regardless of whether started by a simple or an admin-user.

 

The requirement for removing the start page is that the workflow should immediatly start after clicking the action from the ECB instead of clicking "start" on the StartWorkflow.aspx-page.

 

On my local machine, I've got Nintex Workflow 2013 (3.1.5.0) - International installed.

 

I screenshoted the major settings in this workflow as following:

 

nintex1.png

nintex2.png

nintex3.png

nintex4.png

 

Is this a known bug or an expected behaviour? And if, how could this be fixed?

 

Greetings from Nuremberg

Ricky

 

Nachricht geändert durch Ricky Mattischeck: corrected spelling mistake in subject

Outcomes