Known Issue: Workflow error when configuring the From Address in K2 Cloud

  • 16 February 2021
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Known Issue: Workflow error when configuring the From Address in K2 Cloud

KB002613

PRODUCT
K2 Cloud

 

Issue

In K2 Cloud, you configured a sender's email address in the From email field on any of the following workflow steps:

  • Send Email step
  • Task step - Task Notification
  • Task step - Email Reminder

At runtime, the workflow fails with the following error: SourceCode.Worklfow.Common.EWS: The e-mail address name@emaildomain.com does not have 'send on behalf of' permission on Exchange.Image

 

 

Cause

To configure the From address, you need to make sure that this person has the necessary sharing (delegation) permissions to send an email on someone's behalf. Delegate Access allows them to manage another person's email. 

 

In K2 Cloud sometimes email addresses are different than the K2 Cloud domain, which means that the K2 service account is not available when you're setting up delegation for the From address functionality to work. K2 Cloud uses Office 365 browser-based mail, and it's not always possible to configure delegation as required.

K2Service

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User email address

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This means that when you try to configure the Delegate Access in your K2 Cloud environment, the K2 Service account is not available for you to select.

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If the account is available for you to select, the following error shows when you try and finish the configuration.

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Workaround

There is no workaround as you cannot configure delegation access for the From address in a K2 Cloud environment. For this reason, the From address field is no longer available for configuration in the steps mentioned at the beginning of this article.

 

 

 

 

 


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