Code Fix: When using K2 smartforms to update a User/Group column in SharePoint, the column is not updated

  • 16 February 2021
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Code Fix: When using K2 smartforms to update a User/Group column in SharePoint, the column is not updated

KB001935

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When using K2 smartforms to set or update an item in a SharePoint Document Library or List with a custom Content Type containing a User/Group column, the column remains empty.

 

 

Cause

Custom Content Types were not handled correctly.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 May 2017 Cumulative Update FP6 from Regional Support.
  4. Install the K2 4.7 May 2017 Cumulative Update FP6 to apply the fix.

 


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