Code Fix: Error occurs after installing K2 (5.2) Fix Pack 21, which causes the K2 Host Service to stop working

  • 16 February 2021
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Code Fix: Error occurs after installing K2 (5.2) Fix Pack 21, which causes the K2 Host Service to stop working

KB003120

PRODUCT
K2 Five 5.3
K2 Five (5.3) Fix Pack 1

 

Issue Description

If an environment has SQL 2014 installed with large data in the 3 columns below, then the index (IX_SyncEngine_IdentityProperty_ProviderInstanceID_Name_Value) fails to create when the Entity Framework migration executes, which prevents the K2 server from starting up correctly.

 In the SyncEngine.IdentityProperty table: 

  • ProviderInstanceID
  • Name
  • Value

Error Message

The following error occurs: “MigrateDatabase.Execute: Logged Error: Failed: System.Data.SqlClient.SqlException (0x80131904): Operation failed. The index entry of length 1050 bytes for the index 'IX_SyncEngine_IdentityProperty_ProviderInstanceID_Name_Value' exceeds the maximum length of 900 bytes.

Warning! The maximum key length is 900 bytes. The index 'IX_SyncEngine_IdentityProperty_ProviderInstanceID_Name_Value' has maximum length of 1540 bytes. For some combination of large values, the insert/update operation will fail.

The statement has been terminated."”

Cause

Issue introduced by K2 (5.2) FP 21

Resolution

  1. Ensure you have K2 Five (5.3) installed.
  2. Download the K2 Five (5.3) FP1 from K2 Partner and Customer Portal.
  3. Install the K2 Five (5.3) FP1 to apply the fix.

 


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