Code Fix: Numerous errors occur in the Host Server logs when logging into the K2 Mobile application

  • 16 February 2021
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Code Fix: Numerous errors occur in the Host Server logs when logging into the K2 Mobile application

KB002066

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When logging into the K2 Mobile application, a K2 Pass-Through Authentication failed error appears numerous times in the HostServer.log file.

 

 

Error Message

The error message in the HostServer.log file will be similar to:

210352547","2017-08-22 10:59:48","Error","Communication","8130","ConnectionPacketError","SourceCode.SocketService.Legacy::HandlePacket","8130 Error processing message from 10.128.7.30:64623: 3012 K2 Pass-Through Authentication failed. Current Host Server configuration prevents switch to non-Windows identities.","","","BKK2APP01:C:Program Files (x86)K2 blackpearlHost ServerBin","210352547","500f602d650545419488724e4b548bc9",""

 

 

Cause

Enabling Anonymous Authentication and Windows Authentication at the same time caused problems with Integrated Authentication validation.

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and install the K2 4.7 August 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 August 2017 Cumulative Update FP10 from Regional Support.
  4. Install the K2 4.7 August 2017 Cumulative Update FP10 to apply the fix.

 


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