Latest Posts

REST call to Microsoft Graph with a nested object ...

I am trying to extend my K2 implementation to assign tasks to a person when creating or updating a task in Planner using Microsoft Graph and the REST...

  • By jem1
  • August 26, 2020  19:01
  • 762
  • 0
  • 5

Connecting K2 Five to Planner on Microsoft Graph u...

If it is of any help I wrote a post about my experience with connecting K2 to Microsoft Graph using the REST broker. https://blog.ozippy.com/pos...

  • By jem1
  • September 01, 2019  17:18
  • 226
  • 4
  • 1

Finding the AAD App registration for using the RES...

I am trying to configure the Inbound OAUTH to use the REST API with K2 Five. I am reading https://help.k2.com/kb002870 and https://help.k2.com...

  • By jem1
  • March 06, 2019  22:04
  • 180
  • 0
  • 1

K2 Upgrade from K2 4.6.11 to K2 Five

If anyone is planning to upgrade from K2 4.6.11 to K2 Five, this is a summary of the approach we took and some of the issues we faced. https://ozipp...

  • By jem1
  • January 28, 2019  23:36
  • 342
  • 0
  • 1

Migrating solutions from 4.6.11 to Five on differe...

I am considering setting up a new instance of K2 Five separate to my 4.6.11 instance with a view to migrating over time one process/solution at a tim...

  • By jem1
  • September 24, 2017  16:04
  • 4608
  • 0
  • 8

SharePoint 2013 Form Viewer App Part

I have upgraded to SharePoint 2013 and have qute a number of K2 Form Viewer web parts which pass parameters to the forms to display the correct data ...

  • By jem1
  • May 17, 2016  16:03
  • 457
  • 0
  • 0

Securely connect on premise K2 with Office 365?

I am currently examining if it is feasible to utilise the K2 app in Office 365 with my on-premise K2 server. When I read the doco, it seems to indica...

  • By jem1
  • April 13, 2015  00:18
  • 113
  • 0
  • 1

I don't get any email notifications from the K...

I have my profile and settings configured to receive email notifications from the community, but I don't receive any. This makes it quite difficult t...

  • By jem1
  • December 01, 2014  21:35
  • 405
  • 0
  • 2

Dynamically specifying which view to load

I think this is related to another post http://community.k2.com/t5/K2-blackpearl/Loading-K2-Smart-Forms-Views-runtime-Dynamically/m-p/72900#M20917 ...

  • By jem1
  • December 01, 2014  18:06
  • 84
  • 0
  • 1

Accessing a list of data in a workflow

I don't know if I am missing something obvious here, but I need to ask the question anyway. The premis is that I want to manipulate a list of dat...

  • By jem1
  • November 12, 2014  20:37
  • 96
  • 0
  • 2

Master Detail, displaying the detail for the first...

I want to have a master/detail SmartForm with two list views in it. When the user clicks a list item in the first view, it displays a list of detail ...

  • By jem1
  • October 12, 2014  20:23
  • 776
  • 0
  • 5

Conditionally displaying a list view if it contain...

I am trying to conditionally display a view on a SmartForm. The view is connected to a List event of a SmartObject from a SQL database. I start o...

  • By jem1
  • October 12, 2014  20:15
  • 320
  • 0
  • 6

Access to the 'Worklist Item Instance' in ...

I am creating some email escalations on events in my workflow, and I would like to construct the same email notification that I sent in the event not...

  • By jem1
  • August 04, 2014  15:14
  • 2018
  • 1
  • 10

Cross domain access to Smartobjects

I am currently contemplating an architecture for allowing JavaScript based access to data. I would like to take advantage of smartobjects. In looking...

  • By jem1
  • March 04, 2014  13:35
  • 271
  • 1
  • 3

Disaster Recovery Topology

I am working on a design which requires a highly available solution on one site and a hot DR environment on another site. So I figure I can setup a l...

  • By jem1
  • October 12, 2007  06:05
  • 107
  • 0
  • 2

WPF wizard issues in Visual Studio

The WPF Wizards in Visual Studio operate inconsistently. I find that sometimes the dropdowns do not drop down, the ellipses to show a dialog som...

  • By jem1
  • August 24, 2007  06:20
  • 1853
  • 0
  • 5

The site http://<server>:<port>/ could...

It looks like there is a bug in the RTM of BlackPearl with regard to enabling the K2 Features from Central Administration. After installing BlackPe...

  • By jem1
  • August 24, 2007  06:16
  • 74
  • 0
  • 1

K2Error.aspx is missing from the Central admin

After installing and configuring BlackPearl RTM, I can get the server to start but when I go to MOSS Central Admin, if I click on any of the features...

  • By jem1
  • August 24, 2007  06:08
  • 689
  • 0
  • 4