"Invalid reply url" error is shown when navigating to any K2 URL after an upgrade or configure.

Topic

After an upgrade or configure of the K2 environment, the below error is shown when navigating to any K2 URL (Runtime, Designer, Management, Workspace, ViewFlow):

 

"System.IdentityModel.Protocols.WSTrust.InvalidRequestException: Invalid reply url :'<expectedURL>/Runtime/' for realm: '<configuredURL>/Runtime/'. If this reply address is correct please configure an appropriate audience for this realm. at SourceCode.Security.Claims.Sts.Controllers.WsFedControllerBase.Index() at SourceCode.Security.Claims.Sts.Windows.Controllers.wsFedController.Index()"

 

chruff_0-1618343225855.png

Instructions

This is likely due to the wrong site binding being selected during an upgrade or configure of the K2 environment. Note that this error is also often seen when the http binding is accidentally selected when the https binding is expected (or the reverse).

It is possible to resolve this by updating the K2 SmartForms Runtime and K2 SmartForms Designer web.config files to reflect the correct runtime urls.  In each .config file, the below node will be present:

 

"<wsFederation passiveRedirectEnabled="false" issuer="http://none" realm="<configuredURL>/Runtime(or /Designer)/" requireHttps="false" />"

 

Updating the realm="<configuredURL>/Runtime(or /Designer)/" to "<expectedURL>/Runtime(or /Designer/" in both files may resolve the issue. 

 

If it does not, the issue can also be resolved by running the Setup Manager using the Configure option.  When prompted to select the K2 site on the "K2 Site Configuration" step, click 'Use an existing Web site' then click on 'Bindings.'  Ensure the correct binding is selected, then click 'Ok' and proceed to finish the Configure.

 

Additional Information

 

 

Related Links

Labels: (2)
Version history
Revision #:
1 of 1
Last update:
3 weeks ago
Updated by:
 
Contributors