Worklist control filters updated in K2 Designer are not reflected for some users

  • 16 February 2021
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Issue

The filters that have been updated in a worklist control on K2 Designer are not being reflected for some users when they open the form or view containing that worklist control.

 

Diagnosis

Users can set their own filters on the worklist control. These filter settings are stored in the K2 database, and will overwrite any filters you have predefined on the worklist control.

 

New users using the worklist control for the first time, and users who have not changed the filters in the worklist control will not face this issue.

 

But whenever a user sets the filter in the worklist control from your form or view, that filter will be saved into the K2 database. When the same user opens the worklist control again, the same filter the user has previously set will be loaded instead of the predefined filter configured on the worklist control from K2 Designer.

 

Resolution

If you need the filters you have configured in K2 Designer to be pushed out to all users, you will need to delete the worklist control from your form or view, re-add the control and configure your filters again. This action will remove any custom filters that your users may have set.

 

If you do not want users to have the ability to set their own custom filters, you can uncheck the "Show Filter" property for the worklist control in K2 Designer.

 

If you do not want to delete and re-add the worklist control, an alternative is to delete the filter settings that users have created for the worklist control from the K2 database. Please reach out to Nintex Support if you need assistance with removing user's filter settings from your K2 database.

 


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