Showing results for 
Search instead for 
Did you mean: 

Profile Property Source Field is Empty Using Set Variable Action with User Profile

When using a “Set variable” action in Nintex Wworkflow, and setting any property related to user profile, such as department or About me or last name, the “Source” field under Set Variable action is empty.

Option 1  

Start/Restart User Profile Services:
  1. Go to Central Administration.
  2. Navigate to System Settings > Manage Services in the farm > User Profile Service. 
  3. If this service is stopped, click Start, or try restarting this service. 

Option 2

Check the App Pool account Permissions for User Profile Services:
  1. In Central Administration, go to Application Management > Manage Service Applications.
  2. Click on User Profile Service and in the ribbon click on Properties.
  3. Check the Account and the database used to access the Profile Database. 
  4. In SQL Management Studio, go to the Profile Database listed.
  5. Expand Security > Users and check for the app pool account in the list.
  6. Verify user account is listed, if not, add the user account. 
  7. If the user is listed, make sure the app pool account has the right permissions. 
Labels: (1)
Version history
Revision #:
2 of 2
Last update:
‎02-05-2019 09:21 AM
Updated by: