Code Fix: Non-expiry K2 licenses show an expiration date in K2 Management

  • 16 February 2021
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Code Fix: Non-expiry K2 licenses show an expiration date in K2 Management

KB002466

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

In K2 Management > Licenses, the expiration column shows the expiration date of a license. However, when a non-expiry license is present in the list, the value in the expiration column shows as 01/01/2007, instead of the phrase No Expiration.

Cause

The SmartForms rule that applies styling to K2 Management > Licenses did not accommodate a non-expiry license. The Forecolor of the text in the Type, Expiration, Licences Key and System Key columns also needs to show in the default color of a non-expiry License.

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 March 2018 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 March 2018 Cumulative Update FP11 from Regional Support.
  4. Install the K2 4.7 March 2018 Cumulative Update FP11 to apply the fix.
  5. It is recommended to refresh the browser cache.

 


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