No ratings

Autocomplete Control Disabled At Runtime


Autocomplete Control Disabled At Runtime

This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.


When a view contains a control which is linked to the AD user SmartObject datasource, with this being enabled it appears to work as expected as the data is displayed properly at runtime.

However, once this same view is added at form level the auto complete control is disabled and no data can be retrieved here.



This happens when a view is created with an auto complete control and the AD User SmartObject is used as the datasource. This is then binded to a form with the rule set up as the following: 


 If the View is Enabled = No on the Form at first Form initialize, then when the Selector is changed, the View is changed to Enabled = Yes by a Rule and initialized.


With this set up the auto-complete control does not work. 




The workaround here is the following:


- At form level rule configuration when a button is clicked

- Choose to Enable the view

- Enable view control. This is where you choose to select the auto-complete control.


This will also be addressed within future releases of K2.

Labels: (1)
Version history
Last update:
‎05-20-2021 06:52 AM
Updated by: