cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

"nintex workflow 2013" menu item missing from Site Settings

When I create a new web application, the "Nintex Workflow 2013" menu option is missing from the site settings (gear) drop-down menu.  All of the requisite activations for the web application, site collection features, site features, and setting under the CA Web Application activation have been configured.  I am operating with full control site permissions.  I have two previously configured SharePoint web applications configured in the same farm that DO show the "Nintex Workflow 2013" menu option on site collections configured for Nintex Workflow and I am able to configure new site collections and activate them and the menu option appears.  Attempts at site configurations in new web applications do not show this menu item.

Any assistance would be appreciated.  Thanks.

Labels: (1)
Reply
11 Replies
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

Have you tried deactivating and reactivating the Nintex Workflow 2013 feature at the site level ?

Hope this helps

0 Kudos
Accept as Solution Reply
Not applicable

Re: "nintex workflow 2013" menu item missing from Site Settings

Hello,

I'm having the same issue. I've reactivated features and added safecontrols to the web.config:

1:  <SafeControl Assembly="Nintex.Workflow.ProjectServer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=913f6bae0ca5ae12" Namespace="Nintex.Workflow.ProjectServer.ServerControls" TypeName="*" Safe="True" SafeAgainstScript="False" />

   2:  <SafeControl Assembly="Nintex.Workflow.ServerControls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=913f6bae0ca5ae12" Namespace="Nintex.Workflow.ServerControls" TypeName="*" Safe="True" />
   3:  <SafeControl Assembly="Nintex.Workflow.ServerControls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=913f6bae0ca5ae12" Namespace="Nintex.Workflow.ServerControls.WebParts" TypeName="*" Safe="True" />

But still no result.

Is there another way to create a reusable workflow in Nintex without this menu?

Cheers,
Thijs


0 Kudos
Accept as Solution Reply
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

Have you also tried to deactivate and reactivate the features at the site collection level and web application level (before doing this, be sure that you've saved your workflows and the related data) ?

To create a reusable workflow Template without the Nintex menu, you can try to access this url (for SharePoint 2013) :

http://your-SharePoint-site-url/_layouts/15/NintexWorkflow/WorkflowDesigner.aspx?Category=Reusable

Hope this helps

Accept as Solution Reply
Not applicable

Re: "nintex workflow 2013" menu item missing from Site Settings

Hello Caroline,

Reactivating on web app level did the trick. Thanks for the quick reply!

Cheers,
Thijs

Accept as Solution Reply
Not applicable

Re: "nintex workflow 2013" menu item missing from Site Settings

Here is what I have discovered.  I have managed to resolve this problem, or, at least I have found a work-around.  I actually stumbled across what appeared to be the problem discovering that using a port number other than 80 on the web application, the “Nintex Workflow 2013” menu option would not display on the settings (gear) drop-down.  In my case I was using port 8080 on a new web application dedicated to training and research in our development farm.  At one point I used PowerShell to set up an alternate URL (Set-SPSiteUrl) using port 80 to point to the URL using port 8080 and discovered that the menu option appeared when accessing the alternate URL. Interesting.  I also did the same thing in a path based site collection using the CA to set an alternate URL (Set-SPAlternateUrl) and achieved the same results.  When accessing the site collection alternate URL (port 80) the menu option appeared but when accessing the original URL (port 8080), it did not appear.

It turns out that if you use the Disable-SPFeature PowerShell command as an attempt to re-initiate the installation of the feature by re-enabling the feature (Enable-SPFeature), the re-enabling process will return an error message indicating a licensing issue.  I noted that the license is for the name of the web front-end server and my new web application uses a different URL. Both web applications share the same application pool so I am wondering - speculating if that has anything to do with the alternate URL working since the original web application URL was initially set up for port 80.  In any case, it is working even if in a round-about way.  Other more experienced folks may have a more precise explanation. 

Accept as Solution Reply
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

Alternate URLs can cause a lot of side effects. You could even configure it in a way that prevents search from reaching your site. So there are many things to consider/review in the setup of a web application with using AAM. And if you also use Host Names, then there is even more to consider. I apologize I'm not as precise as you are asking.

Are you using AAM because you have users coming from different zones? Or just because you needed to change the default zone's URL? There may be a better setup to strengthen your farm so these cross URLs don't cause other issues.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

I just experienced that issue within a new demo web application. In my case the cause was an incomplete (or simply forgotten) SharePoint deployment of the Nintex solutions. Here's what helped me out:

Make sure that the nintexworkflow2013.wsp is deployed to the web application hosting your site collection (or try redeploying it). This puts some safe control entries into the web.config of that web application (without them, SharePoint will not render the custom action in the site settings menu). Thijs' Post pointed me right into that direction

As Caroline already proposed, make also sure that the Nintex features on web application, site collection and web site level are activated.

After these steps I was ready to go via site settings menu, hope this helps someone else out!

Greetings

Manu

Accept as Solution Reply
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

I had them same issue, everything was working perfectly except view site workflow action.

The NintexWorkflow.wsp was not deployed to my webapp !

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: "nintex workflow 2013" menu item missing from Site Settings

I had the same issue, in my case it was working in one web front end and not working in other. Finally found out all web config file was not updated in that particular WFE finally add all entries to the web config. Then Nintex Start working for all users..

Finally wrote a blog post for same.

"Nintex 2013 Workflows" Option Not available in SharePoint 2013 Site Menu - Get-SPNote  

Accept as Solution Reply