cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

"Email Notification" Erroring Workflow due to Email Address Trying to Resolve

We have an email address which is a real AD account with an email address associated to it. It has a Group Scope of Global and a Group Type of Security. When entering this email address into a Nintex Workflow Notification action, the email address (which I enter as an External Email ) tries to Resolve itself which results in returning "company\cer_superadmin" or just "cer_superadmin" and the following error:

"Failed to send notification. Cannot get the full name or e-mail address of user "cer_superadmin@company.com"."

I have tested the email address by sending directly to it from my email account and it works fine.

I found this information which helps a little.... but doesn't really explain what to do about it:

"You can assign a notification to an external email address, but even if you do so it will still try to resolve it first. This is because values that are entered into the action can be dynamic (item properties, variables, etc), so at runtime it tries to work out if its a user / group / external email, and attempting to resolve it is a part of this process."

Also, here is the information from the error logs (if this helps at all):

10/27/2014 16:24:41.70  w3wp.exe (0x264C)                        0x0C30 Nintex Workflow 2010           General                        0000 Unexpected  (http://company/CapitalExpenditure/_layouts/NintexWorkflow/preview.aspx?ListId=257f8efe-929f-4285-9f5...:( Nintex.Workflow.NWActionExecutionException: Failed to send notification. ---> Microsoft.SharePoint.SPException: Cannot get the full name or e-mail address of user "COMPANY\cer_superadmin".     at Microsoft.SharePoint.Utilities.SPUtility.GetNTFullNameandEmailfromLogin(SPRequest request, String login, String& displayName, String& email)     at Microsoft.SharePoint.Utilities.SPUtility.GetFullNameandEmailfromLogin(SPWeb web, String login, String& displayName, String& email)     at Nintex.Workflow.HumanApproval.UserInfo.GetDisplayNameAndEmail(SPWeb web, String login, String& displayName, String& email)     at Nintex....

10/27/2014 16:24:41.70* w3wp.exe (0x264C)                        0x0C30 Nintex Workflow 2010           General                        0000 Unexpected ...Workflow.HumanApproval.Message.GetMailAddress(User user, NWWorkflowContext context, Encoding encoding, ConfigSettings configSettings)     at Nintex.Workflow.HumanApproval.Message.GetEmailAddressForUser(User user, NWWorkflowContext context, Encoding encoding, ConfigSettings configSettings)     at Nintex.Workflow.HumanApproval.Message.SendEmail(String subject, User user, NWWorkflowContext context, NWContextDataCollection ctxData, MailAddressCollection toAddresses)     at Nintex.Workflow.HumanApproval.Message.Send(NWWorkflowContext context, User user)     at Nintex.Workflow.Activities.SendMessageActivity.Execute(ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)     at System.Workfl...

10/27/2014 16:24:41.70* w3wp.exe (0x264C)                        0x0C30 Nintex Workflow 2010           General                        0000 Unexpected ...ow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.Runtime.Scheduler.Run()     --- End of inner exception stack trace --- (Build:2360)

Environment:

  • SharePoint 2010 Enterprise Edition
  • Nintex Workflow 2010

Hoping someone can help!

Labels: (1)
0 Kudos
Reply
12 Replies
Nintex Employee
Nintex Employee

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Hi Sheila,

is this an email address for an AD User or an email address associated with an AD group?

At this stage, Nintex Workflow only supports sending emails to AD Security Group and not AD Distribution groups.

I'm wondering if that is the issue here.

cheers,

Vadim

0 Kudos
Reply
Not applicable

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

I believe this is an AD Security Group, correct? Please see image below:

ADInfo.jpg

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

hmm ok.  Then it should be working.  I suggest you open a support ticket - support@nintex.com .

0 Kudos
Reply
Not applicable

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Thanks. That's what I ended up doing. Will post back as to what I find out.

On Wed, Oct 29, 2014 at 1:28 AM, vadim.tabakman@nintex.com <

0 Kudos
Reply
Not applicable

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Received notification from Nintex that we are running an older version of software 2.3.6.0 released on 12/12/12 and they recommend updating to 2.4.0. So they recommended updating to see if that fixes the problem. Will keep you posted.

0 Kudos
Reply
Automation Master
Automation Master

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Just curious if that update resolved your issue?

0 Kudos
Reply
Not applicable

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Hi Shiela,

Did you get any update on this? Even I'm facing the same issue and ours is an updated version of Nintex 2013

0 Kudos
Reply
Nintex Newbie

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Hi,

we are also facing this issue. Any ideas or fixes?

We'd like to send e-mails to users, who are members of an AD-group that has been placed into a sharepoint-group.

Regards - Markus

0 Kudos
Reply
Nintex Newbie

Re: "Email Notification" Erroring Workflow due to Email Address Trying to Resolve

Hi Sheila,

Not sure if this has been answered. But a manual solution i did was i pick external address and type the address manually and it seemed to work for me.

Hope this helps

Regards - Ric

0 Kudos
Reply