cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

"Copy to User Doc Library" not working

I have read this post: https://community.nintex.com/thread/3702. It still does not work for me.

  • I am using SharePoint 2013
  • My users have contribute access to the site 
  • I have the Copy to User Doc Library step within an Action Set
  • I have the Action Set "run as workflow owner. By the way I am running it and I *AM* the workflow owner. Still no go. 
  • I have a pause of 1 minute before the Copy to User Doc Library step. 
  • Both the source List and the destination Library are under the same site

I have a List that I have created a simple Nintex Form for when the user is to submit a document. This form ensures that they complete the metadata before attaching the file. I do this because we cannot attach any files to a document library new item form. When they submit the form, the file should be copied to the library specified along with the metadata. 

Have there been any changes since 2015 that might shed light on why this step of the workflow simply does not work? 

Thanks,

Susan

0 Kudos
Reply
1 Reply
Workflow Hero

Re: "Copy to User Doc Library" not working

I wrote the Errors to a workflow variable and sent myself the variable results. The result is:

When I hover over the "Copy to Sharepoint" step in my workflow designer, it specifically states: "Copy attachments to {library URL}.:

So if I am adding an attachment to a new list item, and I want to copy or move that attachment to a Document Library, what am I supposed to use? 

I go to my Document Library Properties and get the library URL directly from that, so I know the URL is correct. 

I read up on Content Types and they are different for Lists and Documents, so I can't use the same Content Type in both the source list and the destination library. 

I tried again after unchecking the "copy metadata" box, and still the same error. 

Help please....Thank you.

Susan

0 Kudos
Accept as Solution Reply