cancel
Showing results for 
Search instead for 
Did you mean: 
muhskhan
Nintex Newbie

isdlg=1 is not allowing to navigate the nintex form

Hello,

 

isdlg=1 is one of the good sharepoint features where you can hide left navigation and headers if you use it in your url. It works fine with the default SharePoint forms. However, when i use isdlg=1 in nintex classic form, it doesn't navigate to either source url or redirect url, instead it stays in the form.

 

What is the reason behind?

 

Labels: (1)
Tags (3)
0 Kudos
Reply
3 Replies
Community Manager Community Manager
Community Manager

Re: isdlg=1 is not allowing to navigate the nintex form

The form is being rendered through Nintex, not SharePoint, but you should still be able to see the left nav show/hide based on adding that to the URL. You may want to add it to the URL right after before the "source" to allow it to render correctly.

orderform3.JPG  orderform1.JPG

0 Kudos
Reply
chanteldup
Nintex Newbie

Re: isdlg=1 is not allowing to navigate the nintex form

I don't think the problem is it not rendering correctly, I tested it and it does, the problem is that clicking the Save/Cancel/Submit buttons do not redirect like they are supposed to.

 

I tried recreating this with the following scenarios:
1. Leave Redirect url field blank in both forms setting and all button configuration settings
- This causes a blank screen to load when clicking any button
2. Configuring a Redirect URL in either form settings or any button config, or both
- This causes the form to just remain in the current state, no redirect of any kind.
3. Configure button as JavaScript button with redirect function
- same behaviour as above

I have for interest sake inserted a link to see if it would override all URL's but it doesn't, links still function correctly.


0 Kudos
Reply
Jan999
Nintex Newbie

Re: isdlg=1 is not allowing to navigate the nintex form

I have the same problem... any update on this?

0 Kudos
Reply