cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Workflow Hero

isNullorEmpty rule condition not working

In Nintex form, I have disabled a button with rule condition isNullorEmpty(textfield) based on another text field. If the text field is empty or null, then this button will be disabled.

The rule seems to work for the first time only. When the form was loaded, the button was disabled until I enter something into the text field. However, the button was not disable when I go back and delete all the data in the text field.

Does anyone have this similar issue?

Please share your thought.

Thanks,

Emily

Labels: (1)
Tags (1)
Reply
16 Replies
Workflow Hero

Re: isNullorEmpty rule condition not working

Hi ‌, can I know which Nintex Forms version are you using?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Hi Abdullah,

Version 2.11.0.1.

We have upgraded to this version recently.

Regards

Emily

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

I assume you are using Nintex Forms 2013, right?

Weird, I'm using the latest version and the isNullOrEmpty() function seems to work fine.
Everytime I remove text, the button is disabled and adding back text, the button is enabled.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

I go back and delete all the data in the text field.

did you as well leave the text field after you deleted content?

check developer console whether there are not reported any errors.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Abdullah - That's correct. I'm using Nintex Forms 2013.

Marian - Yes. I did leave the text field after deleted content.

I have figured out the root cause of this issue. It's not working because my text field is a "Multiple Line of Text" with the "Plain Text" SharePoint (SP) column setting. If I change it to "Enhanced rich text (Rich text with pictures, tables, and hyperlinks)", the button work perfectly.

However, I come across another issue, if I change my text field SP column setting to "Enhanced rich text (Rich text with pictures, tables, and hyperlinks)", the text field was disabled (not able to type anything) when the form was loaded. Can anyone please shed some light?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Hi,

I would check that you haven't applied your rule to the text field accidentally. There should be no reason for it to be disabled unless it is either defined in the control setting or there is a rule applied. Regardless of this, the fact that the field is a plain text or Rich text should not impact the result if you are wiping the content from the field.

Cheers,

Mark

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Are you really talking about formatting rule?

or did you configured an appearance settings formula?

can you post a screenshot what and how exactly you configured it?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Hi,

I just did a quick test and cannot replicate the issue. With a multiline text control added to the form and connected to a Instruction column defined the same as you have (with plain text), the rule works without issue. When there is no text in the field, the button is disabled. When I type, the button is enabled and when I remove the typing , the button disables again.

Have you tried switching the rule around so that your Instruction rule applied to the submit button and the Comment rule to the Save button. Or have you tried not having it connected to the columns at all - this would totally rule out the column definitions being a reason for the issue?

Cheers,

Mark

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: isNullorEmpty rule condition not working

Hi All,

 

I managed to resolve my second issue where the multiple text field was disabled after I switched the List column to "Enhanced rich text (Rich text with pictures, tables, and hyperlinks)".

I suspect the Panel somehow blocked this field in Nintex form.

Set the field to “Bring to Front” has fixed issue.

 

 

However, my first issue still not resolve.

Here is the simple settings of my form.

 

First column (Comments) setting in SharePoint List, with “multiple lines of text” type and Enhanced rich text (Rich text with pictures, tables, and hyperlinks)” option.

Second column (Instruction) setting in SharePoint List with “multiple lines of text” type and Plain Text” option.

 

The rule settings in Nintex form look like this.

For Save button, it is disable when the Comments multiple text field is null or empty. For Submit button, it is disable when the Instruction multiple text field is null or empty.

When the form first loaded, these two buttons were disabled.

The Save button was enabled when I type something in Comments, disabled when I remove the text.

 

However, the Submit button was not disabled, when I type the text in Instruction and then remove the text.  I have tried moving my cursor to other field but the Submit button still enabled.

So the issue was “isNullorEmpty” only work for Multiple lines text with Enhanced rich text (Rich text with pictures, tables, and hyperlinks)” option.

 

Cheers,

Emily

Accept as Solution Reply