cancel
Showing results for 
Search instead for 
Did you mean: 
sarasafari
Nintex Newbie

fn-FormatDate doesn't work

Hi everyone,

I have a Nintex responsive form with a text field named Year, I'm going to set default value for a Year as the current year.

Here is the configuration:

it always return the actual formula and not year.

If I change the datatype to Integer or Decimal it shows the following error:

Even if I set value using rules, still it doesn't  work:

any idea would be appreciated!

Labels: (1)
0 Kudos
Reply
5 Replies
Automation Master
Automation Master

Re: fn-FormatDate doesn't work

What's your form's version?

Can you try the same with classic form's?

0 Kudos
Reply
sarasafari
Nintex Newbie

Re: fn-FormatDate doesn't work

hi Martin,

Yes same behavior in both Responsive and Classic.

Nintex version, SharePoint on-prem 2013 

0 Kudos
Reply
Automation Master
Automation Master

Re: fn-FormatDate doesn't work

I experienced just the same problem on classic forms on just the same forms version (haven't tested with responsive forms).

I've reported it as a bug to nintex support a week ago.

I was just advised to upgrade to latest release 2.11.4. haven't had chance to do so, however.

you may try it, if you are able to upgrade or already did so.

but I do not believe it will get fixed with that release since I do not see listed any related fix in release notes.

0 Kudos
Reply
sarasafari
Nintex Newbie

Re: fn-FormatDate doesn't work

Hi Martin,

 

I'm experiencing the same on both Responsive and Classic.Nintex suggested to upgrade to the higher build. However in the organization I work, it takes months to upgrade to a new version! 

0 Kudos
Reply
Automation Master
Automation Master

Re: fn-FormatDate doesn't work

FYI, so I've tested it on 2.11.4.0 last week and it seems it got fixed.

it yet worked correctly, at least in my environment.

Reply